Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am getting the following error while trying to insert a row in a table:

Attempt to fetch logical page (1:12032) in database 19 failed. It belongs to allocation unit 72057594069450752 not to 72057594051166208.

What could be the reason?

share|improve this question

migrated from stackoverflow.com Jan 21 '12 at 19:04

This question came from our site for professional and enthusiast programmers.

    
you should accept Tareq's answer if it solved your problem –  gbn Jan 21 '12 at 18:54
add comment

1 Answer 1

I think you have a database corruption so try the command

DBCC CHECKDB

And The command

 dbcc checktable ( 'dbo.TableName', REPAIR_REBUILD )

Before that Refer to BOL to see about the commands .

share|improve this answer
    
Thanks Tareq.. the command worked..Now the error is gone.. –  Karthick M Mayan May 30 '11 at 4:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.