Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have Linux Red Hat 5, with Zend Server and MySQL Server installed.

I am trying to change the default MySQL port to 512. However, after making this change, MySQL will no longer startup. I get the error below:

Starting MySQL...The server quit without updating PID file 

How do I resolve this issue?

share|improve this question

migrated from Feb 1 '12 at 13:46

This question came from our site for professional and enthusiast programmers.

try delete the pid file. – xdazz Feb 1 '12 at 8:50
i have tried to delete it and restart mysql again. and i have got the same error message. – user1182245 Feb 1 '12 at 9:23
Use 'tail' to view error log to identify problems during start up. At your RedHat bash shell type: service mysql start ; tail -f /var/lib/mysql/error.log Or whatever your path to the error log is. – randy melder Sep 11 '12 at 22:03

You say that you are trying to change the MySQL port from 3306 to 512. If that is correct, then then problem is that all *nix (Linux, Solaris, AIX, etc) require you to run as root in order to bind to ports below 1024.

Try running it on port 3307 or something.

share|improve this answer
I have logined as root account. I have changed the port to 1433, then restart linux. I am still got the error Starting MySQL...The server quit without updating PID file (/var/lib/mysql/ – user1182245 Feb 2 '12 at 2:33
Please post your my.cnf. Is there anything else in the error log? – Aaron Brown Feb 2 '12 at 14:10

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.