Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

We have a fairly high end box running mysqld 5.5.20.

The cpu configuration is dual quad core xeons.

It has 32 gb ram.

It has a quad intel ssd configuration running raid 0+1.

On a fairly busy service what starts to happen is that after about 18 to 24 hours of being up, once in a while, every few hours, there will be a 1min period where ALL inserts will start stacking. The strange thing is that using mytop even memory table inserts / updates are shown as executing for 'many' seconds.

More ofen then not even without a restart it will return to normal.... only to do it again.

A restart always fixed the issue, for another 18 to 24 hours.

All munins look ok.

Help!

share|improve this question
    
Some scrubbed copies of innodb status and process list when the problem is occurring would be helpful –  atxdba Feb 7 '12 at 21:21
    
MyISAM or InnoDB tables? Please provide your my.cnf, SHOW ENGINE INNODB STATUS\G, and SHOW FULL PROCESSLIST –  Aaron Brown Feb 8 '12 at 12:34
    
100% innodb tables. Will add the show engine innodb status to original question. –  anonymous-one Feb 8 '12 at 16:50
    
In your question, when you said even memory table inserts / updates are shown as executing for 'many' seconds, do you mean that you have tables that use the MEMORY storage engine? –  RolandoMySQLDBA Feb 8 '12 at 18:15
    
Maybe you are experiencing so-called InnoDB "furious flushing" issue. You could check if that's the case for checking if buffer page write activity spikes at the same time query performance drop. –  Laurynas Biveinis Feb 21 '12 at 12:38

1 Answer 1

Similar to my problem if you have the performance_schema enabled, solved after the upgrade of MySql server version.

Starting from 5.5.16 to 5.5.22 is affected by a deadlock. No queries can be run when it happens: Bug 13898343 - THREAD LOOPS ENDLESSLY IN LF_PINBOX_PUT_PINS WHILE HOLDING LOCK_THREAD_COUNT

An infinite thread loop could develop within Performance Schema, 
causing the server to become unresponsive. (Bug #13898343)

See changelog

First of all try disabling performance_schema

Hope his helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.