Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

In SQL 2008 Server Management Studio: is there a way to keep intellisense from always picking the longest word to autocomplete? For example, I could be trying to type the word client and it'll autocomplete with clientdetails.

share|improve this question
    
Which version of SSMS? I'm using 10.50.1600.1 and do not have mentioned problem. –  Coder Hawk Feb 19 '11 at 9:46
    
@Sandy I'm on version 10.0.4000.0. That might be part of the problem. :) I'll look for SP updates and see if that helps. –  Bryan Denny Feb 21 '11 at 13:40
    
@Sandy Actually, this microsoft.com/downloads/en/… says 10.0.4 is SP2? Am I missing something? –  Bryan Denny Feb 21 '11 at 13:43
    
I thought that, 10.5 is 2008R2, 10.0 is 2008. Not sure if that helps. –  RateControl Feb 25 '11 at 1:33
    
I'm on 10.50.2500.0 and have the same issue. Very annoying. –  Head of Catering Mar 7 '13 at 21:17

1 Answer 1

I find it easier to just disable IntelliSense, the more I use it, the less I like it. Although before I tried it, I loved it :)

Just better to learn to hand-code things correctly. Mostly IntelliSense intefere's with that

share|improve this answer
1  
au-contraire. Autosense helps me type even faster than my normal 50-60 WPM, with autocompletion and learning how to use it. I agree that while it's still building it's database it takes time for it to catch up, especially on larger projects, but on small stuff it makes things blazingly simple. –  jcolebrand Feb 25 '11 at 15:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.