Sign up ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm running SQL Server 2008R2 Developer on W7 x64, as the default instance. For some reason, SQL Server's performance counters seem to have disappeared. SELECT * FROM sys.dm_os_performance_counters returns zero rows.

I tried running lodctr /T:perf-MSSQLSERVERsqlctr.ini. Although it completed without errors, it didn't fix anything, even after restarting the Remote Registry service. In fact, the counters are now missing from perfmon. unlodctr MSSQLSERVER still says that the counters are not installed, but lodctr /Q:MSSQLSERVER says they're present and enabled. Regular Windows and .NET counters are working fine.

In the Windows Error log, I'm seeing Error 8317:

Cannot query value 'First Counter' associated with registry key 'HKLM\SYSTEM\CurrentControlSet\Services\MSSQLSERVER\Performance'. SQL Server performance counters are disabled.

I suspect the problem may have been triggered by an installation of SQL 2012 RC0 that failed. Any suggestions for how to recover, short of reinstalling SQL 2008R2?

share|improve this question

migrated from Feb 23 '12 at 8:09

This question came from our site for system and network administrators.

You mean "Visual Studio 11" (not "2011"?) – gbn Feb 23 '12 at 7:58
Yes, VS 11. The problem with the question on serverfault is that none of the posted answers resolved the issue. I'm hoping DBA-oriented users might be able to provide more useful help. – RickNZ Feb 23 '12 at 8:11

4 Answers 4

Have a try with lodctr /R, it will rebuild all performance counters from informations stored in registry.

share|improve this answer
In my case there were more counters missing, not only SQL Server's. lodctr /R did the trick and restored them all. Thank you very much for the trick. – Endrju Sep 13 '13 at 18:44

Read through this:

The exact instructions are not 100% correct. You need to do this, assuming you are using the default instance:

lodctr perf-MSSQLSERVERsqlperf.ini

Then reboot.

share|improve this answer
I found that symbolfile path in my perf-MSSQLSERVERsqlctr.ini was incorrect. I fixed it, executed lodctr /T:perf-MSSQLSERVERsqlctr.ini, lodctr perf-MSSQLSERVERsqlctr.ini and restarted SQL Server. – Der_Meister May 2 at 13:44

Missing performance counters is recurring issue.

Some known solutions are listed here:

share|improve this answer

It looks like the Performance Counters for SQL Server are DISABLED or the registry entries for the performance counters are corrupted.

lodctr /E:MSSQLSERVER will reload the performance counter registry settings.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.