Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am trying to edit the SSIS Back Up Database Task And it gives the folowing error

Property BackupDirectory is not available for Settings 'Microsoft.SqlServer.Management.Smo.Settings'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

share|improve this question
1  
Was this SSIS package created by you? I looks like you do not have the proper permissions. –  StanleyJohns Feb 24 '12 at 1:44
add comment

2 Answers 2

This is a known issue with SSIS designer (although I cannot find the Connect article at this time). Most likely the backup value key in the registry is not being updated correctly with the directory for this package.

To fix this (if you are on the default instance), launch Regedit and navigate to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer\MSSQLServer. Create a string value called "BackupDirectory" (no quotes) and in the value put the complete path of your backup directory. Then restart and your issue should be resolved.

For a named instance, the Regedit path is:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\"name of your SQL instance"\MSSQLServer

share|improve this answer
add comment

I also got the same error while restoring a local copy of SQL Server database.To get rid of this error you need to create a string value and key field in the registry.Name the string field as BackupDirectory and in the value field write the path of the backup directory. You need to create this registry entry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server. For detailed information with screenshots refer this guide.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.