Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

now i am working with memcached with mysql cluster 7.2 for that i am installed

libevent-1.4.14b-stable.tar.gz
memcached-1.4.5.tar.gz
libmemcached-0.8.tar.gz

then

memcached_functions_mysql-0.8.tar.gz

i have installed first 3 successfully but while installing memcached_functions with

./configure  --prefix=/usr/local/ --with-mysql=/usr/local/mysql/bin/mysql_config

i am getting error like

checking for DEPS... configure: error: Package requirements (libmemcached >= 0.17) were not met:

can any one help me out in finding the solution...

thanks in adv

Deepak M

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

i found the solution for the previous case

the DEPS ERROR mainly because of not setting the path

while installing the libevent,memcached,libmemcached i gave the prefix with /usr/local path....in that path all the library files are created and while installing memcached function we need to set the environment variable to the path as shown below

export PKG_CONFIG_PATH=/usr/local export DEPS_CFLAGS=/usr/local export DEPS_LIBS=/usr/local/lib

later its succesfully configured and working

regards Deepak M

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.