Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have two computers running SQL Server 2008 Express: c01 and c02, I setup both for remote connection using windows authentication. Worked fine for c02 but not for c01.

This is the error message I'm getting:

Cannot connect to ACAMP001\SQLEXPRESS.


ADDITIONAL INFORMATION:

Login failed. The login is from an untrusted domain and cannot be used with Windows authentication. (Microsoft SQL Server, Error: 18452)

For help, click: http://go.microsoft.com/fwlink?>ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=18452&LinkId=20476

I don't know if I'm missing something, here is what I did:

  1. Enabled TCP/IP protocol for client from Sql Server Configuration Manager.
  2. Modified Windows firewall exceptions for respective ports.
  3. Started the Sql Browser service as a local service
  4. Added Windows user to this group: "SQLServerMSSQLUser$c01$SQLEXPRESS"
  5. From Management Studio, I added "SQLServerMSSQLUser$c01$SQLEXPRESS" to SQLEXPRESS instance's logins under security folder, and I granted sysadmin permissions to it.
  6. Restarted c01\SQLEXPRESS
  7. Restarted Sql Browser service.
  8. There is no domain here. It's only a workgroup.

Please any help is appreciated, Thank you.

share|improve this question
add comment

migrated from stackoverflow.com Mar 15 '12 at 12:30

This question came from our site for professional and enthusiast programmers.

3 Answers

I think you should be able to use the runas command to set up your connection in SSMS. Create a shortcut on your desktop (or wherever), and set this as the target location:

runas /user:DOMAIN\account /netonly C:\path\to\ssms.exe

If this is a workgroup, then DOMAIN may be the name of the computer SQL Server is installed on. Obviously, the account you're setting here will have to exist on the computer hosting SQL Server.

This setup also works for domain users trying to connect to a SQL Server instance in another domain.

share|improve this answer
    
(Just noticed that this was an old question. Oh well!) –  bhamby Apr 16 '12 at 16:18
add comment

Try 'mixed authentication mode' and see if that helps. I've seen this error with the opposite configuration (i.e. trying to login with a SQL user on a system set up only with Windows Authentication).

share|improve this answer
add comment

Whatever username you are using on the "remote" machine must be set up on the "server" machine.

So, if you are logged-in to "remote" as "John," there must be a "John" user on the machine that is hosting SQL Server 2008 Express, and unless you are going to provide different credentials, it should have the same password, too.

share|improve this answer
    
I've already done that. Thank you though. –  mbadawi23 May 3 '10 at 16:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.