Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I go to Tools > Options > Environment > Keyboard and
Type in Query.Sp_whoisactive
Press shortcut keys: Ctrl+F1
Click Assign.

When I press Ctrl+F1, It still calls Help.

share|improve this question
Does that stored procedure actually exist in your instance? That is not an ms-shipped SP. Can you run it manually? – Thomas Stringer Apr 6 '12 at 16:19
Also did you try EXEC master..sp_whoisactive (assuming you created it in master)? – Aaron Bertrand Apr 6 '12 at 17:51
@AaronBertrand Isn't that unnecessary, as a prefix of sp_ causes SQL Server to look in the master database first anyways? – Thomas Stringer Apr 6 '12 at 18:03
The EXEC was more the key – Aaron Bertrand Apr 7 '12 at 7:17
I had the same issue, I've logged it on Microsoft Connect – Paddy Apr 18 '12 at 10:59
up vote 3 down vote accepted

Click on Tools > Options. Then navigate to Environment > Keyboard > Query Shortcuts. In the stored procedure column next to Ctrl+F1, type Sp_whoisactive.

Next navigate to Tools > Options > Environment > Keyboard > Keyboard, and find the command Query.CustomSP1. Assign the shortcut Ctrl+F1. Then search for the command Help.ViewHelp and remove the mapping for Ctrl+F1 there.

share|improve this answer
Ah, good catch. The OP probably didn't change it in the Query Shortcuts part, but the main Keyboard section. – Thomas Stringer Apr 6 '12 at 18:19
I still can't assign Ctrl+F1 combination. But Ctrl+3 works – ob213 Apr 6 '12 at 19:14

In Sql Server 2012, control + F1 is assigned to View Help (Check the Help menu in SSMS). I don't think now we can re-assign to some other functionality. But still I'm not sure why the Control+F1 option is provided in Query Short cuts. So there may be a provision to re-assign this also. Not sure, we have to explore the new features in Sql Server 2012.

share|improve this answer
This is not true, or at least not always: I've used Ctrl-F1 for sp_whoisactive in MSSS 2012 and 2014. – Jon of All Trades Oct 30 '14 at 16:09

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.