Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Setting innodb_flush_log_at_trx_commit = 2 improves my application performance considerably on my local development environment. The response time and number of requests per second on a 40 concurrent users benchmark is improved by a factor of 8, at least.

However, on my testing environment at Amazon RDS, which is a clone of my production environment, absolutely nothing changes. My benchmark results from after and before setting it to 2 are virtually the same. The server was rebooted and the right value is there when querying for SHOW VARIABLES.

I expected improvement wouldn't be as much as with a local server, but I expected something at all, even if not worth the consequences. Any ideas on what might be wrong? Does Amazon RDS doesn't update it immediately somehow or loads default settings from somewhere else?

share|improve this question

1 Answer 1

Trying this today I get "rds-modify-db-parameter-group: Malformed input-The parameter innodb_log_file_size cannot be modified." so I guess they disabled that, which is pretty silly.

share|improve this answer
    
If you're having a problem please post a new question using the "ask a question" button on the top right of the page. –  jcolebrand Feb 8 '13 at 21:06
    
I'll give a +1 because I learned 4 months after that post that innodb_log_file_size was fixed at 128M. You can never resize them. My apologies, and +1 for catching this. –  RolandoMySQLDBA Feb 8 '13 at 21:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.