Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I cannot get dacpac working on my installation of MS SQL Server 2008 R2. I am using Visual Studio 2010 Shell with MS SQL Server Data Tools to build a project into a dacpac file. However, when I try to deploy it, I get the following error:

<DacType xmlns='http://schemas.microsoft.com/sqlserver/dac/Serialization/2012/02'> was not expected. (6di0urgg)

(This seems to indicate that it is using a xml schema that the 2008 server does not know, however in the project properties the target platform is set to SQL Server 2008 R2)

Just to see how the "correct" dacpac file looks like, I tried to Extract/Register Data-tier Application (of a very simple existing database) via Management Studio. Everything seems to go smoothly, but then the export dies with the following message:

Method not found: 'Void Microsoft.SqlServer.Management.SqlParser.Metadata.IdentityColumnInfo..ctor(Int64, Int64, Boolean)'. (Microsoft.SqlServer.Management.SmoMetadataProvider)

Googling for these error messages yields no relevant results (as far as I was able to tell). Can anybody advise? Is anybody using dacpacs?

share|improve this question
    
I was able to register a sample database once I switched identity columns off on 2 tables. –  user8668 May 9 '12 at 14:54
    
Hi I have the same problem. I now exported a DACPAC from SQL2008R2 it seems that the DacMetadata.XML has no namespace at all, the other namespaces have /2010/ instead of /2012/ I have removed the namespace from my SSDT2012 dacpac and tried to publish again, know I get an error that other files are missing. My SSDT2012 project settings are also set to 2008 or 2008R2. Strange that no 2008R2 DACPAC is created by the build. Any solutions yet? Regards Florian –  user9968 Jul 6 '12 at 8:25
    
I switched to using PostgreSQL for this particular task, and buying Toad Data Modeler to get the functionality of creating scripts to alter database after deployment. Our database is actually quite small and does not require the "enterprise" features of MS SQL. –  martin Jul 9 '12 at 16:54
add comment

closed as too localized by Marian, StanleyJohns, Mark Storey-Smith, RolandoMySQLDBA, Max Vernon May 24 '13 at 10:42

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

protected by Community Sep 27 '12 at 7:56

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged or ask your own question.