Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am using linux platform. I also dump the data into a file and I restore into a server and I ran this command

[root@localhost /]# mysqldump -u root -p fms  < /device.sql

The funny part it keep running and this dump only consist of table data and I see other table data being run when I run this command where is the other table data comes from?

share|improve this question
up vote 1 down vote accepted

I think you meant this:

mysql -u root -p fms < /device.sql 

This will import SQL from /device.sql into the fms database

mysqldump only outputs and is not designed to input anything

Doing this

mysqldump -u root -p fms

will echo the mysqldump all all tables currenly in the fms database

share|improve this answer
Sorry rolando I got it was my mistake overlook it. – newbie14 Apr 26 '12 at 5:43

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.