Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Does anyone else's phpmyadmin take an incredibly long time to load? like 68 seconds after i click a table it finally gets there...!

its also very slow when i click the "add data from text file into table" button...

is there anything that can be done to speed it up?

share|improve this question

closed as too localized by JNK Oct 16 '12 at 16:49

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
We'd need to know a lot more about your setup before attempting to answer this–can you provide that? –  Jack Douglas Oct 16 '12 at 7:48
    
I did a fresh install of the whole server, this time i could use this solution because i did not have any valuable data. Thanks! –  Charas Override Oct 16 '12 at 16:15
    
See stackoverflow.com/a/14351073/470749. Paste these lines into the bottom of your config.inc.php file within your phpMyAdmin installation: //http://future500.nl/phpmyadmin-slow-on-startup/: $cfg['MaxExactCountViews'] = 0;//disable trying to count the number of rows in any view $cfg['MaxExactCount'] = 0;//disable correcting the InnoDB estimates Thank you to future500.nl! I wish I'd found this fix hours earlier, before I accidentally deleted all my data. :-( –  Ryan Jan 16 '13 at 3:50
    
Since this is pretty high on the Google results, I figured I'd share a solution that worked for me: in the config.inc.php try changing the "host" value from "localhost" to "127.0.0.1". This saved 90% of the page load time for me. –  Martijn Hols Feb 8 at 15:28

1 Answer 1

Are these slow tables under any kind of access from other applications? If the tables are being placed under an explicit read lock that could be blocking phpmyadmin. There could be an implicit lock by a large insert going on as well.

If it's taking that long you should be easily able to run a show processlist from a straight command prompt to see if you PMA user is sitting locked, sending data, nor maybe nothing at all on the database side.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.