Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Everything was working fine until this moment I want to create a new database and I'm receiving this error

db_create.php: Missing parameter: new_db (FAQ 2.8)

Also when I was trying to export my database I also receive the following error

export.php: Missing parameter: what (FAQ 2.8)
export.php: Missing parameter: export_type (FAQ 2.8)

When I looked it FAQ 2.8 from the suggested link in PHPMYADMIN

2.8 I get "Missing parameters" errors, what can I do?

Here are a few points to check:

  • In config.inc.php, try to leave the $cfg['PmaAbsoluteUri'] directive empty. See also FAQ 4.7.
  • Maybe you have a broken PHP installation or you need to upgrade your Zend Optimizer. See http://bugs.php.net/bug.php?id=31134.
  • If you are using Hardened PHP with the ini directive varfilter.max_request_variables set to the default (200) or another
    low value, you could get this error if your table has a high number
    of columns. Adjust this setting accordingly. (Thanks to Klaus
    Dorninger for the hint).
  • In the php.ini directive arg_separator.input, a value of ";" will cause this error. Replace it with "&;".
  • If you are using Hardened-PHP, you might want to increase request limits.
  • The directory specified in the php.ini directive session.save_path does not exist or is read-only.

I did tried with php.ini to make sure that I've session.save_path = "/tmp"

I'm using Mac Xserver and running with MAMP I did tried everything to restart my server and nothing help.

Can someone please make a suggestion on the same?

My apologies if I have posted this in the wrong place!

share|improve this question
    
I don't have an answer but your question might be better targeted on the PMA forums sourceforge.net/projects/phpmyadmin/forums/forum/72909 Your issue sounds pretty application specific –  atxdba May 3 '12 at 6:15
add comment

1 Answer 1

This might also happen if you disable the cookies in your browser. If this is the case, you may see this message:"Cookies must be enabled past this point" on the top of Phpmyadmin page. All you need to do is to enable cookies on your browser, or use different browser to log to phpmyadmin.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.