Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am running the command:

/usr/bin/mysqlcheck -hlocalhost -uDATABASE_NAME -pPASSWORD --auto-repair --check --optimize DATABASE_NAME

And up until this past week, this command has always run just fine. Last week however, I started receiving the error:

Error : Table 'DATABASE_NAME.H1#~i' doesn't exist 
status : Operation failed

This is not a table I created or recognize. I have no idea why the error would suddenly start occurring. Has anyone seen this or have any idea what might be causing this?

share|improve this question
    
Did you recently upgrade mysql or switch from a Oracle build to a Percona build or similar? –  kormoc Jan 27 '13 at 8:29
add comment

1 Answer

Here is the original command that you ran

/usr/bin/mysqlcheck -hlocalhost -uDATABASE_NAME -pPASSWORD --auto-repair --check --optimize DATABASE_NAME

Since you are running mysqlchk against the database, you need to specify the --databases option

/usr/bin/mysqlcheck -hlocalhost -uDATABASE_NAME -pPASSWORD --auto-repair --check --optimize --databases DATABASE_NAME

Give it a Try !!!

share|improve this answer
    
--databases is only required when specifying multiple databases in a single command line –  kormoc Jan 27 '13 at 8:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.