Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Is there a way to tell the VALIDATE RECOVERY FILES command to use a different location with more available disk space?

When I run the command in RMAN, it fails with the following error stack:

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03009: failure of validate command on ORA_DISK_1 channel at 06/05/2012 12:02:42
ORA-19502: write error on file "/opt/app/oracle/product/11.2.0/dbhome_1/dbs/...
ORA-27072: File I/O error
Additional information: 4
Additional information: 1071488
Additional information: 286720
ORA-19502: write error on file "/opt/app/oracle/product/11.2.0/dbhome_1/dbs/...

This appears to be due to the fact that the validation is using the database home for it's work area and there isn't enough disk space there. I can actually see the 8GB free there drop to zero before the command fails and the space is returned.

This location is not affected by setting the location in the format when allocating the channel for the device.

DB_RECOVERY_FILE_DEST is set to '+FRA', but currently most of the backups are in /u01/back rather than ASM. '+FRA' does have some control file backups.


I haven't found a way to do this, but I also haven't found anything definitive saying it is not possible. There is an Oracle community topic discussing this, but no resolution. Interestingly RESTORE ARCHIVELOG ALL VALIDATE and RESTORE VALIDATE DATABASE CHECK LOGICAL do not exhibit this behavior, which may be why more people haven't run into it.

Update 2:

I opened a SR with Oracle support to see if they can shed light on this question.

Update 3:

Oracle support was able to reproduce this issue in house and they are treating it as a bug.

share|improve this question
Create a directory on another mount point with more free space and symbolic link it. – Phil Jun 5 '12 at 23:08
@Phil Have you tried this? Do you know that this is the only way around the problem or are you just tossing it out as a potential workaround? – Leigh Riffel Jun 6 '12 at 13:30
@Phil Also, how would I create a symbolic link to replace an existing folder. Are you suggesting I delete folder and replace it with a symbolic link? – Leigh Riffel Jun 6 '12 at 14:04
up vote 3 down vote accepted

Oracle Support closed bug 14226856 as "not a bug" and said it will be fixed in 12c.

share|improve this answer

Check db_recovery_file_dest parameter, I suspect it is not configured and Oracle is using oracle home as default.

share|improve this answer
It is configured and is set to an ASM disk group with plenty of free space. Is it because the backup files being verified are already in that location that it is using another location? – Leigh Riffel Jun 6 '12 at 13:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.