Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to connect Oracle Forms 10g version (9.0.4) to the Oracle 10G Enterprise Edition.

At first I tried to connect to the db without setting the "Local Net Service Name Configuration" in Oracle Net Configuration Assistant.I got the errorenter image description here

After setting the "Local Net Service Name Configuration" in Oracle Net Configuration Assistant, I am still getting an error

enter image description here

Can anyone explain me how to connect to the database with forms as I am stubbed as of long struggle for connecting the database?

# tnsnames.ora Network Configuration File: C:\oracle\product\10.2.0\db_1\network\admin\tnsnames.ora
# Generated by Oracle configuration tools.

    (ADDRESS = (PROTOCOL = TCP)(HOST = = 1521))
      (SERVICE_NAME = orcl)

      (SID = PLSExtProc)

The following are the listener.ora and tnsnames.ora contents

# listener.ora Network Configuration File: C:\oracle\product\10.2.0\db_1\network\admin\listener.ora
# Generated by Oracle configuration tools.

    (SID_DESC =
      (SID_NAME = PLSExtProc)
      (ORACLE_HOME = C:\oracle\product\10.2.0\db_1)
      (PROGRAM = extproc)

      (ADDRESS = (PROTOCOL = TCP)(HOST = RahulSingh-PC)(PORT = 1521))
share|improve this question

migrated from Jun 18 '12 at 2:54

This question came from our site for professional and enthusiast programmers.

The message is an indication of incompatibility of Forms version that you're using with your OS, i.e. Windows 7.

You'll need to install Oracle Forms version with patchset 3 to have this corrected.

Else you can also install Oracle Forms 11g R2 which is certified for Windows 7

share|improve this answer
OK.Thanks for the help.let me download Oracle forms 11g R2 and install it and then check if everything goes right.:) – Rahs Jun 17 '12 at 18:49
@Rahs it should work fine. Keep me posted. – Sathya Jun 17 '12 at 18:52
Hi I have installed 1.WebLogic 10.3.5(wls1035_win32.exe) 2.Oracle Forms And Reports11. Both have been installed successfully. Now when I am trying to connect to my database(Name-ORCL Using scott/tiger) I am still getting the same error ORA-12154: TNS:could not resolve the connect identifier specified Could you please assist me once again as I am in deep trouble for a long time regarding this connection error.Please help me. – Rahul Singh Jul 6 '12 at 19:59
looks like the database's listener services is not running. launch services.msc & ensure that you have the TNS listner service running @Rahs – Sathya Jul 7 '12 at 14:17
thanks for the help.I have figured out the solution.thanks for your support.. – Rahul Singh Jul 7 '12 at 18:01

Add this to both tnsnames.ora or

hr = (SID_LIST = (SID_DESC = (SID_NAME = hr) (ORACLE_HOME = ) (PROGRAM = extproc) ) )

share|improve this answer
It might help future visitors if you explained why this works. – Max Vernon Nov 14 '12 at 20:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.