Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I use sqlplus and all non-Latin characters appear as '?' when I run select queries. When I run insert or update queries with non-Latin characters I get question marks on a web page.

select * from nls_database_parameters; gives NLS_CHARACTERSET: AL32UTF8. I've exported the NLS_LANG variable: export NLS_LANG=RUSSIAN_CIS.AL32UTF8, but this didn't make any changes.

What is the problem? Of course I use UTF-8 working in Linux terminal and I can see the script file contents executing cat script.sql.

If I execute alter session set nls_language='russian' I also face with question marks in ora-xxxxx messages.

share|improve this question
    
Are the table columns defined as varchar2 or nvarchar2, and if the latter, what's your national character set (NLS_NCHAR_CHARACTERSET in nls_database_parameters)? –  Alex Poole Jun 20 '12 at 16:30
    
Thank you for replying, Alex. NLS_NCHAR_CHARACTERSET in nls_database_parameters is UTF8, but the table columns are defined as varchar2, like: "NAME" VARCHAR2 (20 CHAR). –  Kremchik Jun 21 '12 at 8:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.