Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm using Toad to write queries agains an Oracle database. When I write table_name. I get an auto-suggestion menu with all the column names. But if I choose a column name, both the table name and column name is written by uppercases. Is there any way to change this to be written in lowercases instead?

In View > Formatting Option > Case "Identifiers" are set to Lowercase

share|improve this question

2 Answers 2

up vote 2 down vote accepted

I found the following on Quest.com. It works, but may have undesirable side effects.

  1. Go to View | Toad Options in the main menu.
  2. On the left-hand side of the options window go to Editor | Behavior.
  3. Under the Language section, click on the Syntax highlighting button.
  4. In the new window, under styles on the left hand side, select "Indentifer" and select Lowercase for Capitalization effect on the right hand side.
  5. Under styles on the left hand side, select "Toad_user_table" and select Lowercase for Capitalization effect on the right hand side..
  6. Click on Apply and OK.
share|improve this answer

Click on the following menu items:

View -> toad options -> Editor -> Behaviour

Then check Use lowercase object names from select windows

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.