Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm having problems with importing data into a SQL Server 2008 database.

If I execute the following statement in SSMS, it works fine.

INSERT INTO 
    [dbo].[ObjectiveRatingTranslation]
( 
    [ObjectiveRatingId]
,   [TranslationId]
,   [Abbreviation]
,   [RateName]
,   [Description]
,   [CreatedBy]
,   [CreatedOn]
,   [ModifiedBy]
,   [ModifiedOn]
)
VALUES
(
    3
,   29
,   N'O / T'
,   N'På målet'
,   N'Målet har slutförts i enlighet med detta förväntningar. Uppfyller de slutprodukter som definieras. Det förväntas att de flesta mål bör vara Topplista på denna nivå.'
,   0
,   '2012-03-27T11:49:43.2300000'
,   0
,   '2012-03-27T11:49:43.2300000'
)

If I have this statement in a script file that is being executed by VS 2010, Database, Deploy. The data gets imported as

P� m�let | M�let har slutf�rts i enlighet med detta f�rv�ntningar. Uppfyller de slutprodukter som definieras. Det f�rv�ntas att de flesta m�l b�r vara Topplista p� denna niv�.

Same type of problem happens with SSIS on import to. I'm sure there must be some kind of setting that can be changed, but I"m not sure what.

share|improve this question
    
Silly question, but are you sure the data is being imported like that and it's not a presentation issue? Reason I ask, is when certain fonts can't render a given glyph, they'll use a box placeholder. –  billinkc Jun 27 '12 at 19:37
    
No question is silly. :) The UI is SSMS and when the data is inserted using the insert command from a query window, it display correctly. –  Dwight T Jun 27 '12 at 20:33
1  
Are you sure the file is UTF8/Unicode and not ASCII? –  swasheck Jun 27 '12 at 23:04
1  
Is there way to make it UTF8/Unicode from Visual Studio? I'm able to do it with Notepad++. That was the problem. (Hang's head in shame.) –  Dwight T Jun 28 '12 at 14:37
add comment

1 Answer 1

The data types of the columns you are inserting the text into should be set to nvarchar.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.