Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

After upgrading both sql server and management studio from 2008 to 2012, the management studio 2012 is very slow when new query windows and dialog boxes are opened. Even right click on tables is slow. There is typically at least a 5 second delay before I can start doing anything within a window. This happens every time, even if I open the same window twice in a row. What happens and how could I fix this?

I tried a hit on google where I'd need to modify my hosts file, but that didn't help.

share|improve this question

migrated from stackoverflow.com Jul 11 '12 at 17:48

This question came from our site for professional and enthusiast programmers.

    
Even i have faced this issue when i downloaded the trial version .There is a delay when we open a query window. Probably in their next small release they will rectify this issue –  praveen May 30 '12 at 9:27
    
I'm adding a bounty here because I'm curious as well: I'm using 2012 RTM: (Microsoft SQL Server Management Studio 11.0.2100.60) and consistently get about 8 seconds start up time (even with nosplash and all the tricks below, etc...) –  Michael J Swart Jul 4 '12 at 15:59
    
what are you using a Pentium 4? Seriously, what's the CPU resources? Are you out of harddrive space? 5400 rpm harddrive or 7200? –  Aaron Kempf Jul 5 '12 at 10:29
1  
My hardware should definitely not be a problem. It looks like it's waiting for something - I can operate other programs smoothly while this is happening. –  David Jul 10 '12 at 13:21
    
I'd like to add that I use both Visual Studio 2010 and SSMS 2012 and SSMS is bizarrely slow (VS 2010 is fine though). It seems to be something where it is 'communicating' with the SQL server. –  Joel Mansford Sep 3 '12 at 15:59
show 3 more comments

10 Answers 10

I have the same experience as you when I connect to Server Name "./". By dumb luck I found that I do not experience the performance issue when I connect to Server Name "(local)". There's probably an issue with the way SSMS 2012 resolves the server through "./".

Edit: I don't think it's related to SSMS since I can reproduce the slowness with ./ in an ADO.NET connection.

share|improve this answer
    
+1 for the follow-up edit and clarification. –  Max Vernon Sep 24 '12 at 16:45
add comment

It might has happened that SSMS has imported settings that can not be treated correctly anymore (like connections to some server or maybe some add-in settings).

There is a brutal way to "reset" user-defined settings of SSMS.

Close SSMS, go to folder:

C:\Users\YOURWINLOGINNAME\AppData\Roaming\Microsoft\SQL Server Management Studio\

You will find subfolder "11.0". Rename it to "11.0_", so you can always rename it back. Now start SSMS - it will re-create clean settings and maybe your problem will be solved. If not - delete newly generated "11.0" and rename "11.0_" to "11.0" back and wait for another proposal here ;)

share|improve this answer
    
This did not help, unfortunately. –  David Jul 10 '12 at 13:07
    
Ok. This also might be a behaviour of some add-in, that got corrupted after upgrade. Add-ins register themselves as handlers for some commands or events and system might get unstble if they are missing/throwing exceptions. Actually, v2012 uses another mechanism for registering add-ins, but some add-ins install themselves on all instances. To check, look into this registry key: [HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio\11.0_Config\AutomationOptions\LookInFolder] you will find folders list there. Check all these folders - they must be empty (means you have no add-ins). –  Andrei Rantsevich Jul 10 '12 at 21:21
add comment

I have not personally experienced this issue, however there is a long thread (here) where many people have. The general advice seems to be to related to working with your video driver by either

  1. Installing an updated video driver -OR-
  2. Reducing or turning off hardware exceleration -OR-
  3. Turning off DirectX support

From the thread there was also this answer... "Windows 7 Clean Boot procedure revealed the service Biometric Authentication Service (DigitalPersona DPHostw.exe) was the problem. Disabling the service fixed the problem."

I would be interested to know if any of these approaches work in your case as well, as the thread I found relates to older versions of SSMS, i.e. 2005, 2008 , etc...

share|improve this answer
    
None of the video driver solutions had any effect. I don't have the service installed either. –  David Jul 10 '12 at 13:04
add comment

I would guess the problem is that opening a new connection to your server takes 5 seconds. Why exactly this is the case I cannot tell and it would require a wire trace to analyze and diagnose. You should investigate what protocol(s) are being attempted and what protocol eventually succeed. It could be that your client attempts named pipes first (which depends on SMB) and then falls back to TCP (although the usual delay in such a case is much longer, around 20-30s seconds).

I would recommend you check the order of client protocols in the Client Network Configuration. Check the client used protocol by finding your own entry in sys.dm_exec_connections.

share|improve this answer
    
I don't think this is the problem, because other applications establish connections to the database very fast. –  David Jul 10 '12 at 13:02
add comment

I have the same problem and it turns out Trend Micro Office scan is causing the problem.

I tried everything described in several other similar threads about this problem with no avail. I figured i'll try disable the AV software.. Once Trend Micro Office scan is off, SSMS is lightening fast.

This didn't happen on Windows 7.

share|improve this answer
    
This worked for me, just need to work out how to configure trend now... –  Kyle Dec 30 '13 at 11:28
add comment

It is quick on my computer.

SSMS in SQL Server 2012 now uses the Visual Studio 2010 shell, which is more resource intensive than the shell used by SSMS in SQL Server 2008. I suggest upgrading your computer or using SSMS from SQL Server 2008 R2. You should be able to perform most tasks with the old version.

You could also try installing the latest cumulative update as they will update the client tools as well. The latest version for SQL Server 2012 is currently CU1.

http://support.microsoft.com/kb/2679368/

share|improve this answer
    
My computer should be more than good enough. Unfortunately I don't have the opportunity to install the update because there seems to be some risk of errors installing hotfixes and I can't risk that right now. I saw CU2 has been released now if anyone with the same problem wants to try. –  David Jul 10 '12 at 13:17
    
The current build for SQL Server 2012 is Service Pack 1. support.microsoft.com/kb/321185 –  Shawn Melton Aug 30 '13 at 19:15
add comment

The cause of this is almost always a missing network drive - e.g. if you have a drive-mapping to your laptop, but your laptop is turned off.

The resolution unfortunately is to turn on your laptop (so the drives reconnect) or to disconnect your drives in Windows Explorer (but then you have to reconnect them later).

See here for more info: http://social.msdn.microsoft.com/Forums/en-US/sqltools/thread/64c13a84-3e62-4b0c-a1ce-65fcc78d6787

share|improve this answer
1  
This issue is specific to SSMS 2012 - I doubt an msdn thread from Feb 2010 will be relevant. –  JNK Jul 5 '12 at 12:06
add comment

Could it be that you don't have enough RAM on your computer?

The recommended RAM for SQL 2012 is 4 go. It was 2 go for SQL 2008. http://msdn.microsoft.com/en-us/library/ms143506.aspx

Since you've upgraded from SQL 2008 to 2012, maybe you need more RAM?

share|improve this answer
    
Personally, I'm using 16gb of memory with SSD drives... –  Michael J Swart Jul 4 '12 at 20:51
    
I also have 16gb ram. –  David Jul 10 '12 at 13:01
add comment

One should check the status of the database property "Automatically close" into "Automatically" group.

If true, after each query, the connection will be closed, and re-opened at each new query. That surely slow down your work in ssms. Default is false.

share|improve this answer
add comment

Try disabling the antivirus and then check the performance for sql server 2012 management studio.

share|improve this answer
2  
What is the rationale for this suggestion? –  Martin Smith Aug 25 '13 at 14:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.