Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Before setting up SQL Server snapshot replication, I backed up the database from ServerA and restored it to ServerB. Both servers are running SQL Server 2008 R2 SP1.

In trying to setup snapshot replication from ServerA to ServerB using the GUI, I get the following error:

Msg 14027, Level 11, State 1, Procedure sp_MSrepl_addarticle, Line 582 [dbo].[SYSCOLUMNS] does not exist in the current database.

Yes, that is the name of the table and it is indeed a user table. I ran the setup from ServerA which is the Publisher. The collation is the same between the tables on both servers. If I remove that table as an article, the replication is setup just fine.

I've searched the web on this and I'm stumped. Any ideas?

Thanks! Rebecca

share
    
Did you try looking at the SQL being executed in the profiler or stepping through the stored procedure with the debugger? –  Justin Dearing Jul 30 '12 at 18:38
    
No, I haven't tried that yet. I probably will do that next at this point. Thanks –  user728263 Jul 30 '12 at 18:44
    
I'm guessing a weird dynamic SQL thing. If you want to step into it and set a break point at line 581 we can move this to chat. –  Justin Dearing Jul 30 '12 at 18:50
1  
Thanks to someone on Twitter for also helping to look into the issue, it was determined that it's not possible to replicate tables that are using the same names as system tables/views such as dbo.syscolumns or dbo.sysobjects. –  user728263 Jul 31 '12 at 14:25
    
Big thanks to you, Justin, as well for trying to help me figure this out. :-) –  user728263 Jul 31 '12 at 14:26
show 1 more comment

migration rejected from stackoverflow.com Dec 15 '13 at 7:49

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by Shawn Melton, bluefeet, Max Vernon, Mark Storey-Smith, Michael - sqlbot Dec 15 '13 at 7:49

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – Shawn Melton, bluefeet, Max Vernon, Mark Storey-Smith, Michael - sqlbot
If this question can be reworded to fit the rules in the help center, please edit the question.