Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Is there anyway to turn that off? I'm unable to find anything in options, and they're really a distraction.

share|improve this question
    
Do you mean when using SSMS to generate scripts, or what are you referring to when you see this? –  Eric Higgins Jul 31 '12 at 21:10
    
When you drag the Columns folder to editor Window, the full list of Columns are added without Brackets. If you drag columns individually they have Brackets. –  Gordon Bell Jul 31 '12 at 22:47
    
Now that you mention it, that behavior with the Columns folder is highly buggy. I tried it on a table that has spaces in the column names and the resulting column name wasn't quoted. –  Jon Seigel Aug 1 '12 at 13:07
    
I just noticed the same thing. I agree with Gordon. It's very ugly and very distracting. I think it makes SQL code much harder to read and interpret. –  user15501 Nov 20 '12 at 20:41
add comment

1 Answer

up vote 11 down vote accepted

There isn't a way to prevent this. Microsoft feels that it is better to prevent you from shooting yourself in the foot, probably since the number of people out there who create databases, objects or columns with bad names (e.g. my table or date) or reserved keywords (e.g. log or timestamp) outnumber those who never do so.

There was a Connect item asking for this option, and it was very quickly dismissed and closed as "Won't Fix." And in fact many more users were asking that square brackets be added to places where they previously didn't work.

share|improve this answer
    
Well that's dumb. And SSMS should put brackets around reserved words and bad names, but not everything. It's not an ANSI requirement and is really ugly. This complaint will resurface big time. –  Gordon Bell Jul 31 '12 at 22:36
3  
@GordonBell well it may be dumb but I'm sure the complaints were pretty vocal before, when SSMS didn't do this but people were getting burned by broken scripts for databases where they couldn't control the schema... –  Aaron Bertrand Aug 1 '12 at 0:44
5  
So the only person who can provide the right answer is Microsoft, after they add a feature for you? Good luck. You may want to change the wording of your question, which is currently "is there a way to turn this off?" The answer today is no, whether you like the answer or not. –  Aaron Bertrand Aug 2 '12 at 17:30
1  
C'mon, @GordonBell... –  dezso Aug 2 '12 at 17:40
3  
@GordonBell ctrl + H then replace the [ with nothing then replace the ] with nothing. Problem solved. –  Zane Nov 20 '12 at 22:02
show 5 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.