Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have an SSRS report that can I access from the Web Portal but once I try to access it directly through the URL, I get the following error: Execution 'xxx' cannot be found (rsExecutionNotFound).

I looked at the logs on the Report Server and the error there says userName: mydomain\myusername not found in the database.

But, of course, it is in the database - I can access the report from the Web Portal.

Any ideas?

UPDATE The same link now works, two days later.

share|improve this question
    
If the same link works two days later, does that mean it's no longer an issue? –  jcolebrand Aug 6 '12 at 15:30
    
No, it means its an intermittent issue. Another report is experiencing the same behavior now. –  JHFB Aug 6 '12 at 15:52
    
@JHFB this link seems to describe the same sort of behavior that you are experiencing. –  swasheck Aug 9 '12 at 18:38
1  
@JHFB also, it seems that there could also be a timeout issue. check the activity of the server when you get the error and when you don't get the error. i recommend sp_WhoIsActive –  swasheck Aug 9 '12 at 18:41
add comment

1 Answer

What I have seen in a case like you ask about is you hit a report, and copy the url out and then try to hit it later. Reports have session state, especially if you change paramaters,etc. The url will look like a report url with some funky querystring data added to the end. You can't share that because SSRS can't take your "session state" and then find it later.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.