Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have just downloaded the latest Community Installer (5.5.27) along with the MySQL WorkBench (5.2.41). I clicked OK on all default settings on setup.

When I try to "Open a connection to start querying" on the WorkBench home page and chose "Local Instance MySql 55", I keep getting stuck on a never-ending "Opening SQL Editor" screen ("An SQL Editor instance for "Local Instance MySql 55" is opening and should be available in a moment")

Any idea on what could be wrong ?

EDIT : I am able to access it from command line and query it successfully. But still not from query editor.

share|improve this question
    
Is the mysql service running? Have you tried the Local Administration from the Workbench? –  ypercube Aug 4 '12 at 13:15
    
yes it is running, and I can access Server Administration for local MySQL55 on the WorkBench –  Mika Jacobi Aug 4 '12 at 16:53
    
Then porblem lies with Workbench as you are able to query using command line client. –  Mahesh Patil Aug 6 '12 at 5:44
    
Yes please see edit –  Mika Jacobi Aug 6 '12 at 14:01
add comment

2 Answers

Thanks Mika, I tried your solution in workbench (5.2.41). It worked after I cleared the passwords in the vault (click Manage Connections) and restarted the WorkBench.

To clear passwords stored in the vault, I did the following:

  1. Open MySQL WorkBench the you will see the home page
  2. Click Manage Connection at bottom left corner.
  3. In Manage DB Connections, click Clear button besides Store in Vault...
  4. Close it and restart WorkBench.
  5. Double click Local instance mysql in home page, now you db will popup.
share|improve this answer
    
+1 for telling everyone how to clear passwords. –  RolandoMySQLDBA Feb 13 '13 at 16:09
add comment
up vote 1 down vote accepted

I don't know what happened. I launched a command window, it worked. Then I retried, after clearing the password vault, and it worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.