Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have two sql server S1(2008) and S2(2005).

S2 is added to S1 as linked server.

S2 have a table Product.

When I try to run the code

select ProductID from Product

I get the error:

Location:    rmt_meta.cpp:347
Expression:  fFalse
SPID:        71
Process ID:  3828
Description:     Unknown column in remote index! Skipping.

Any idea?

share|improve this question
That is not an error from SQL Server error. There must something else going on here that you're not telling us. – RBarryYoung Aug 5 '12 at 19:38
What tool were you using to execute your SQL command? And what did you use to see that error? – RBarryYoung Aug 5 '12 at 19:48
Studio Server Management Studio – signetro Aug 7 '12 at 8:09

This KB is the closest thing I can find regarding your error, that would come from SQL Server. I would see if you could find any other errors that may give you more explanation as to the issue. Since this seems to be dealing with XML data I cannot help you that much, have not worked with XML much. Other folks on this forum might be able to chime in though...

share|improve this answer
This was my last option on my list, thank you. I'm glad I did not use this option. – signetro Aug 7 '12 at 8:13

I solved the problem. I dropped all indexes and then recreate them again. DBCC CHECKDB, etc gives me no warnings, no error.

share|improve this answer
Yeah I guess since the error did reference an index it might have something to do with that... – Shawn Melton Aug 8 '12 at 1:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.