Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm a software engineer with some experience on SQL Server but a newbie on Oracle.

I'm attempting to run dbca on a remote linux machine to reconfigure a database that was initially configured to idle with zero memory (so I'm told). Enterprise Manager is not configured properly and my listener.ora is as follows:

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION = 
      (ADDRESS = 
        (PROTOCOL = TCP)
        (HOST = Myhost)
        (PORT = 1521)
      )
    )
  )

This database is not on port 1521, it's on port 15321. I can connect to it using SQL Developer by manually creating a connection with the correct port, etc.

I get the error in the title after I press finish in dbca. There is also a log file that is very long. How do I proceed to fix dbca? Ultimately I need to configure Enterprise Manager.

share|improve this question
    
Windows or linux (server-side)? –  Phil Aug 10 '12 at 0:55
    
@Phil, it's linux. –  ThomasMcLeod Aug 10 '12 at 3:32
add comment

1 Answer 1

As far as I understand, there is a database on the machine. This database should register itself on the listener. It can do so when it knows where - on which port - the listener runs. In you case the listener is on port 15321. To enable the auto registration of the instance, you should make sure that the LOCAL_LISTENER parameter is filled with the correct port number in order to be able to contact the listener. For docu check Oracle® Database Reference 11g Release 1 (11.1)

. oraenv
[YOUR_ORACLE_SID]
sqlplus / as sysdba
-- if the instance appears not to be running:
startup
alter system set local_listener = '(ADDRESS = (PROTOCOL=TCP)(HOST=Myhost)(PORT=15321))';
-- to force immediate registration:
alter system register;

Now your database should be visible in the listener services list listener.ora should look like this - note the PORT =

LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION = 
      (ADDRESS = 
        (PROTOCOL = TCP)
        (HOST = Myhost)
        (PORT = 15321)
      )
    )
  )

check the results:

  lsnrctl services
share|improve this answer
    
I am still learning how all this works, but I guess the listener is on port 1521. I get port 15321 from the lsnrcntl services command. Additional info: when I add a SID_LIST_LISTENER record to listener.ora for db in question, this error goes away (I do get another error though, sometime about timezones). I suppose that forces the database connection to port 1521, and port 15321 goes away. –  ThomasMcLeod Aug 10 '12 at 6:01
    
what does your SID_LIST_LISTENER section look like? –  ipip Aug 10 '12 at 6:39
    
If the lsnrctl reports that it is running on port 15321, it is on port 15321, not on 1521. Search your machine to find that listener.ora that is actually used. It won't be the one shown above. Check /etc/listener.ora $TNS_ADMIN/listener.ora and $ORACLE_HOME/network/admin/listener.ora Entering the SID_LIST_LISTENER makes the registration static, which is OK for simple installation. –  ik_zelf Aug 10 '12 at 9:21
    
@ik_zelf, there is only one listener.ora on the machine. –  ThomasMcLeod Aug 10 '12 at 15:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.