Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

We are trying to create an AG Listener and it errors out on us:

enter image description here

It does however seem to create both the DNS entries and the virtual computer object in AD. However, because of this error message SQL backs out the creation of the Listener.

enter image description here

So far we have tried:

  1. Giving the user that sql runs as permission to create objects in AD
  2. Pre-creating the DNS entries and computer object in AD

The only reference I have found to this is at the following connect article, but I can't figure out what the exact fix is from the broken english: http://connect.microsoft.com/SQLServer/feedback/details/686548/denali-ctp3-incorrect-error-message-when-setting-up-listener-with-no-dns-access .

share|improve this question
    
We just tried removing the second network (10.0.0.105) and the server out in that network from the mix and we were able to create the listener... Going to try adding it after fact. –  Kyle Brandt Aug 14 '12 at 18:01
    
That worked, so it looks like the work around for us was to remove the second network and the server in the network from the AG, create the listener, and then put the server and IP back in the AG and add the IP to the listener. –  Kyle Brandt Aug 14 '12 at 18:07
    
I encountered the same problem (or at least the sequence of events was the same). I couldn't create the listener as part of initial setup, but adding it after the fact was a cinch. I was fully anticipating having to tear it all down and try again. Probably worthy of a blog post - "Don't panic, your cluster is not doomed!" –  Aaron Bertrand Aug 14 '12 at 19:27
    
I was getting same error, and adding AG Listner with two ip addresses (one from each subnet node is part of) and it fixed the error. –  SQL Learner Oct 10 '12 at 19:43
add comment

1 Answer

I was able to resolve this issue in my lab.

I setup an Availability Group between two virtual machines in my lab. I was not able to add the listener as part of the initial setup and also couldn't add it afterwards.

Each server had two network adapters on different sub-nets. When I disabled the 2nd network adapter on each server, I was able to add the listener successfully. I then re-enabled the 2nd network adapters successfully with no adverse effect on the listener.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.