Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I've installed 2 instances of SQL Server 2008 R2 onto our local windows server. For the purposes of testing I've turned off the firewall. I'll get the firewall back up after I manage a successfull remote connection. The server isnt exposed anyway.

TCP\IP is turned on for both instances. The default port is assigned to the Default instance and that one is working fine.

I've assigned 4143 to the named instance but I'm still unable to connect remotely.

I can connect remotely to the default instance just not the named instance. What step or steps am I missing?

share|improve this question
add comment

2 Answers 2

You need to start the SQL Browser service to enable connections to named instances.

Explanation here:

Upon startup, SQL Server Browser starts and claims UDP port 1434. SQL Server Browser reads the registry, identifies all instances of SQL Server on the computer, and notes the ports and named pipes that they use. When a server has two or more network cards, SQL Server Browser returns the first enabled port it encounters for SQL Server. SQL Server Browser support ipv6 and ipv4.

share|improve this answer
    
I had the browser started. Good catch though I forgot to mention that in my initial notes. –  Lumpy Aug 27 '12 at 12:51
add comment
up vote 0 down vote accepted

I needed to clear out the values in the TCP dynamic ports. I had 0 in there.

share|improve this answer
    
good to know that this can be one of the causes! –  yogirk Aug 27 '12 at 12:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.