Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have SQL Server 2012 Local DB Installed, and am connecting to it via (localdb)\v11.0.

When trying to restore a backup file, I get:

TITLE: Microsoft SQL Server Management Studio

Property MasterDBPath is not available for Information 'Microsoft.SqlServer.Management.Smo.Information'. This property may not exist for this object, or may not be retrievable due to insufficient access rights. (Microsoft.SqlServer.Smo)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=11.0.2100.60+((SQL11_RTM).120210-1846+)&EvtSrc=Microsoft.SqlServer.Management.Smo.ExceptionTemplates.PropertyCannotBeRetrievedExceptionText&EvtID=MasterDBPath&LinkId=20476

I have tried setting MasterDBPath string value in:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer\CurrentVersion`

but this hasn't helped.

Anyone have any thoughts?

share|improve this question

migrated from stackoverflow.com Sep 3 '12 at 21:43

This question came from our site for professional and enthusiast programmers.

    
What is the source SQL Server edition and version of the backup file? –  Thomas Stringer Sep 4 '12 at 2:48
    
The backup is from a SQL Server 2012 Developer edition install. –  Andy Neillans Sep 4 '12 at 7:51

2 Answers 2

up vote 1 down vote accepted

Not really a proper solution, but this error does not occur if you create a blank database, then restore your backup overwriting the blank database.

Or you can use the restore T-SQL commands:

RESTORE DATABASE FROM DISK = '' WITH NORECOVERY, MOVE 'example_dat' TO 'C:\Temp\.mdf', MOVE 'example_log' TO 'C:\Temp\.ldf'

share|improve this answer

I had the same problem, and solved it.

You need to add 2 strings in the Windows Registry via regedit.exe at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11E.LOCALDB\MSSQLServer:

DefaultData
DefaultLog                     

For me, their values are both C:\Users\neil\AppData\Local\Microsoft\Microsoft SQL Server Local DB\Instances\v11.0.

share|improve this answer
    
Unfortunately doesnt work for me :( I've tried setting the entries under MSSQLServer and also the CurrentVersion key, but I still get the same behaviour in Management Studio. –  Andy Neillans Oct 4 '12 at 17:41
    
This works if you run as administrator –  Max Toro Apr 16 '13 at 17:58
    
Thanks - this worked for me running as administrator however I did also have to create a third key BackupDirectory which I pointed to a similar directory. –  DaveHogan Jul 6 '13 at 15:35
    
Worked like a charm, thx –  njappboy Feb 4 at 17:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.