Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't find the solution and searching for info doesn't give desired results


  • Server: W2K8 EE 64 bit + MSSQL SE 2K8 R2 64 bit
  • Client: Windows XP Prof 32 bit

Using SSMS on client machine I get the following error:

TITLE: Connect to Server

Cannot connect to <<server-name>>.


Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

For help, click:


A security package specific error occurred. (Exception from HRESULT: 0x80070721) (Microsoft.SqlServer.DTSRuntimeWrap)


A security package specific error occurred. (Exception from HRESULT: 0x80070721) (Microsoft.SqlServer.DTSRuntimeWrap)



When I connect from another 64bit W2K8 server using SSMS it works correctly.

Is there some workaround to make it work? For now I'm using SSMS on remote 64-bit machine, but would like to use it on local 32-bit PC.

share|improve this question
I saw a couple blogs that may indicate it was fixed in R2... are you sure you have SSMS R2 where the problem occurs? – Eric Higgins Sep 17 '12 at 23:04
Yes. On 32-bit machine SSMS version 10.50.1817.0, on 64-bit SSMS version 10.50.1810.0 – BartekR Sep 18 '12 at 8:16
up vote 1 down vote accepted

Finaly got it working. Not quite sure of explanation, but I think it had something to do with Kerberos / NTLM authentication.

SSIS was running under domain account that was not registered with SPN. Changing to "Log On as Built-in Account" as Network Service and restarting SSIS service solved the problem.

But also I'm (almost) sure that I've tried it earlier when I found his thread:

Also these articles explaining Kerberos, NTLM and checking SPN settings were helpful:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.