Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

Our production database is hosted by another company on their domain. I'm able to RDP into the box and login with the credentials they provided me but when I try to login from my local computer on my local domain using SSMS SSMS forces my local credentials. I've tried but can find no way to change these credentials using the SSMS front end.

I attemtped using a shortcut with a target of

C:\...\runas.exe /netonly /user:DOMAIN\USERNAME "C:\...\ssms.exe"

But when SSMS comes up it appears to still be trying to use my local credentials and does not allow me to connect. Is there something I'm missing. How do I tell SSMS that its connecting to a different domain account?

share|improve this question
add comment

1 Answer 1

up vote 3 down vote accepted

That just looks that way because SSMS fills that in with the local credentials even if you passed it something else via command line.

Behind the scenes, it is using the username you specified in the /user: argument. It would be interesting to know what the actual error message is and if you tried - instead of using a shortcut - from running that command directly in a command line window (and not closing the CMD window while SSMS is still running).

I was just using this feature yesterday so I am 100% certain it works.

share|improve this answer
    
Ok I got it to work for me by copy and pasting in the password. not sure why but I'm certain I didnt typo all those times. My developer is still having the issue though. When ssms comes up its not defaulting to the db server were looking to connect too. –  Lumpy Sep 20 '12 at 18:04
    
And are you sure you're using the correct server name? What happens when he pings the name you're trying to connect to? Runas doesn't do anything for you that you can't do otherwise - you still need to be able to connect to the server, and credentials don't change that. –  Aaron Bertrand Sep 20 '12 at 18:18
    
Yeah he can ping and he's using the same database name that is working for me. although his does not default too it when the SSMS login comes up. So he inputs that address and switches to windows login. Would this cause SSMS to overwrite the credentials being used in the background? –  Lumpy Sep 20 '12 at 18:28
    
I don't understand how the address is different - is it the wrong server or the wrong database? You change the database on the Options screen. If it's the wrong server and he used runas /netonly properly, I have no idea why he needs to "switch" to Windows login. That should already be set that way. If it's not, he's doing something wrong, sorry. –  Aaron Bertrand Sep 20 '12 at 18:40
    
When SSMS opens. The servername text box for me contains the IP address for the server. When SSMS opens for him the servername text box contains the name of a local server on our internal network. Is that clearer? Sorry if I'm still being confusing. –  Lumpy Sep 20 '12 at 18:42
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.