Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This morning this problem occurs when my co-worker says they cannot connect to database.

I've checked the server and found that the SQL SERVER SERVICE is currently stopped. The problem is I cannot start it manually I've also tried to start the service in services.msc and there's still no luck.

We are using SQL SERVER 2000 ENTERPRISE EDITION Here the screencaps:

enter image description here

enter image description here

Heres the what it says in the Event Logs

SQL Server is aborting. Fatal exception c0000005 caught.
share|improve this question
Was any instance configuration changed recently? – Thomas Stringer Oct 2 '12 at 12:33
Have you changed permissions on the file system or group membership of the SQL Server service account? You may get a hint at exactly what the server is failing to get past by looking in the SQL Server event log. – darin strait Oct 2 '12 at 14:07
what to the surrounding errors in the event log say? – swasheck Oct 2 '12 at 15:49

You don't mention the version of SQL Server you are running, however, are you up-to-date with updates? There have been fixes for Access Violations in SQL Server that you may not have at this time.

Here is an MSDN post that has some relevance (though it is specific to SQL 2008): sql server 2008 is terminating because of fatal exception c0000005

Access Violations occur because the application has attempted to access memory areas that it doesn't own. That is a problem with code. And quite often there are service packs or updates that address these issues.

Without knowing exactly which version of SQL Server you are running a more specific fix cannot be suggested.

share|improve this answer
Do you have any links or further information that might be of help to the OP? – Max Vernon Oct 2 '12 at 15:06
Given that he's showing Enterprise Manager it's either SQL 7 or SQL 2000. – mrdenny Oct 2 '12 at 16:15
I can only add comments to my own answers (probably because my rep is too low since I'm a noob here) but I would think you can find a bit more info in the Dump file generated when the service crashed. That would be located in your sql server's log directory. It might tell you what it was attempting to access when it died. – Brian Efting Oct 3 '12 at 3:20

That's a permissions problem. Odds are the SQL Server doesn't have access to the database files or the LOG folder.

share|improve this answer
How to fix the permission problem anyway? – Prince Jea Oct 3 '12 at 1:46
Check the fix the NTFS permissions on the files/folders that the SQL Server needs to use. The Account which is running the SQL Server needs to have Modify permissions at the minimum on the LOG and DATA folders as well as the files. – mrdenny Oct 5 '12 at 14:48

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.