Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have installed SQL Server 2008 R2 in mixed mode, but currently issue is I can't use SQL through ip nor ip with port, even I have enabled TCP/IP and open port in firewall too.

I tried to telnet 127.0.0.1 1433 to check whether its working or not but its not connecting I tried almost every possible things but failed in each.

How do I get this to work?

share|improve this question

migrated from stackoverflow.com Oct 6 '12 at 1:19

This question came from our site for professional and enthusiast programmers.

1  
Is this a named instance or the default instance? –  Thomas Stringer Oct 6 '12 at 1:54
add comment

3 Answers 3

By default Sql server may not be listening for TCP/IP connections.

Did you check this stackoverflow question?

Also check start the "sql server agent" service is started.

share|improve this answer
add comment

Odds are that the Windows Firewall is enabled and blocking port 1433. I would check that and set a rule to allow TCP/IP traffic over that port.

share|improve this answer
add comment

Are you using a named instance or a default one?

Did you enabled a remote connection on that instance?

Right click on the server and in the Server Properties dialog under the Connections tab check the Allow remote connections to this server option

In the TCP/IP Properties -> IP Addresses -> IPAII:

For a named instance you should set set the TCP Dynamic Ports to blank and port 1434, for a default instance you use port 1433 (this is a default instance that SQL Server uses). After this step you should restart the SQL Server service for changes to take effect.

In the Programs -> Administrative Tools -> Windows Firewall with Advanced Security select the Inbound rules and New Rule:

  1. For a default instance:

In the Protocols and Ports window: Select the TCP option, and in the Specific local ports text box enter the 1433 port

  1. For a named instance:

Select the UDP option, and in the Specific local ports text box enter the 1434 port

Make sure that your SQL Browser is running if you use post 1434.

If you're trying to connect with an Windows Authentication you may also encounter an error that you're connecting to an untrusted domain.

Also it would be helpful if you'll give the exact error you're getting

Hope this helps

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.