Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

When I try to attach a database in SQL Server Management Studio 2008 (SSMS), I get prompted by this message:

If you are certain that you have added all the 
necessary full-text catalogs, click OK.

Why is this coming up. It didn't use to.

We did make some schema changes but have done nothing with full-text catalogs.

Is there a way to prevent this coming up?

share|improve this question
1  
Are you attaching a pre-2008 database with FT enabled onto SQL Server 2008? You will need to attach FT catalogs which were separately backed up. From 2008 onwards, the FT catalogs are part of the database itself. If you don't attach the necessary catalogs, you will have to recreate the full text indexes to rebuild the catalogs. –  孔夫子 Oct 8 '12 at 0:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.