Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have the following setup

  1. A Windows Server 2008 machine as a domain controller [DC]
  2. A Windows Server 2008 machine running SQL Server 2012 [SQL-A]

[Both machines are virtual and are running on virtual box]

I am logged into both machines as CONTOSO\Administrator

On the DC I create a global security group named domain_group_b in the Users container. Similarly I create a user account named domain_user_b.

However when I try to create Windows Authenticated logins on SQL Server using these accounts it doesn't work irrespective of whether I use Transact-SQL or SQL Server Management Studio. I get an error

Windows NT user or group 'CONTOSO\domain_user_b' not found. Check the name again. (Microsoft SQL Server, Error: 15401)

When I use the "Check Names" feature it does find the user and underlines it. Adding local users works OK.

Any ideas?

share|improve this question
    
I tried the suggestions in this article, but none of them seemed to be the cause of the issue. (How to troubleshoot error:15401) support.microsoft.com/kb/324321/en-us –  Antonio2011a Oct 19 '12 at 2:49
    
How long did you wait after adding them? Normally AD only propagates updates (such as new groups / users) after a certain replication interval. –  Alf47 Oct 19 '12 at 5:13
    
@Alf47 Thanks for the suggestion, but I waited a while before trying. Also I came back the next day and still no luck. –  Antonio2011a Oct 20 '12 at 2:14
add comment

closed as off-topic by Jon Seigel, Max Vernon, Mike Walsh, Kin, Mark Storey-Smith Nov 19 '13 at 19:27

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – Jon Seigel, Max Vernon, Mike Walsh, Kin, Mark Storey-Smith
If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.