Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

in my work we have a software system based on sybase adaptive server any where version 6 installed on a windows server 2008. the system work fine but after a period of time from system start problems starts [this period of time is variable may be hour may be day ... the maximum stability period was one week] the problem is:

the logged in users to system stay connected but newly opened PCs the system can't login and the odbc data sources window appears and a message can't find the server. this problem tell now and as i know has only one solution is to reboot the sql engine or reboot the windows server 2008 system, this is so terrible because all connected PCs will stop the system and this may be in the middle of payment operations and so on...

we called the technical support of the system they can do nothing except clearing the log as it reached 21 MB and they sayed that is very large amount of data in log when he cleared the log system stayed one week stable but now it started stopping again.

also they mentioned that it might be because of cash memory in parameter -c150MB they tried 300 instead of 150 and 120 but noway, i tried to add the parameter -ti1400 to stop automatic disconnecting after period of idle time i expanded it to about 24 hours!!

what shall i do to solve this??

share|improve this question
    
Can you post the command you use to start the database server as well as the contents of the data source? Also note that Adaptive Server Anywhere version 6 was released about 14 years ago. You might want to consider upgrading - version 12 is current. –  Graeme Perrow Nov 4 '12 at 15:54
    
thanks for the quick reply I can't get commandline now but i remember it it has a parameter for .db file path and parameter -c150 for cash and recently i added -ti1440 –  ahmedsafan86 Nov 4 '12 at 16:11
    
I also asked the system software company to install a newer version but they didn't reply for that!! –  ahmedsafan86 Nov 4 '12 at 17:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.