Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm setting up an automatic database backup for a website. When I try to do a backup it comes up with the error"

MySQL error: The 'SHOW PROFILE' feature is disabled; you need MySQL built with 'enable-profiling' to have it working
Could not save backup of database information_schema in 'export/'
File successfully saved as unversed_MC_bans.1348661703.sql.zip
File successfully saved as unversed_MG_ranks.1348661703.sql.zip
File successfully saved as unversed_TYE_TEST.1348661704.sql.zip
File successfully saved as unversed_ads.1348661704.sql.zip

After having a look around I find this;

#1289 - The 'SHOW PROFILE' feature is disabled; you need MySQL built with 'enable-profiling' to have it working

I exported the dump file, this was the code

-- phpMyAdmin SQL Dump
-- version 3.4.7.1
-- http://www.phpmyadmin.net
--
-- Host: localhost
-- Generation Time: Sep 26, 2012 at 05:19 AM
-- Server version: 5.1.62
-- PHP Version: 5.3.14-pl0-gentoo

SET SQL_MODE="NO_AUTO_VALUE_ON_ZERO";
SET time_zone = "+00:00";


/*!40101 SET @OLD_CHARACTER_SET_CLIENT=@@CHARACTER_SET_CLIENT */;
/*!40101 SET @OLD_CHARACTER_SET_RESULTS=@@CHARACTER_SET_RESULTS */;
/*!40101 SET @OLD_COLLATION_CONNECTION=@@COLLATION_CONNECTION */;
/*!40101 SET NAMES utf8 */;

--
-- Database: `information_schema`
--

-- --------------------------------------------------------

--
-- Table structure for table `PROFILING`
--

CREATE TEMPORARY TABLE `PROFILING` (
  `QUERY_ID` int(20) NOT NULL DEFAULT '0',
  `SEQ` int(20) NOT NULL DEFAULT '0',
  `STATE` varchar(30) NOT NULL DEFAULT '',
  `DURATION` decimal(9,6) NOT NULL DEFAULT '0.000000',
  `CPU_USER` decimal(9,6) DEFAULT NULL,
  `CPU_SYSTEM` decimal(9,6) DEFAULT NULL,
  `CONTEXT_VOLUNTARY` int(20) DEFAULT NULL,
  `CONTEXT_INVOLUNTARY` int(20) DEFAULT NULL,
  `BLOCK_OPS_IN` int(20) DEFAULT NULL,
  `BLOCK_OPS_OUT` int(20) DEFAULT NULL,
  `MESSAGES_SENT` int(20) DEFAULT NULL,
  `MESSAGES_RECEIVED` int(20) DEFAULT NULL,
  `PAGE_FAULTS_MAJOR` int(20) DEFAULT NULL,
  `PAGE_FAULTS_MINOR` int(20) DEFAULT NULL,
  `SWAPS` int(20) DEFAULT NULL,
  `SOURCE_FUNCTION` varchar(30) DEFAULT NULL,
  `SOURCE_FILE` varchar(20) DEFAULT NULL,
  `SOURCE_LINE` int(20) DEFAULT NULL
) ENGINE=MEMORY DEFAULT CHARSET=utf8;
-- in use (#1289 - The 'SHOW PROFILE' feature is disabled; you need MySQL built with 'enable-profiling' to have it working)

/*!40101 SET CHARACTER_SET_CLIENT=@OLD_CHARACTER_SET_CLIENT */;
/*!40101 SET CHARACTER_SET_RESULTS=@OLD_CHARACTER_SET_RESULTS */;
/*!40101 SET COLLATION_CONNECTION=@OLD_COLLATION_CONNECTION */;

And this is the original query I am trying to run

mysql> SET profiling = 1; 

#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'mysql> SET profiling = 1' at line 1

Any inclinations of why this is happening would be fantastic... Thanks.

share|improve this question

migrated from stackoverflow.com Nov 8 '12 at 19:44

This question came from our site for professional and enthusiast programmers.

    
As it is clearly mentioned in the error message that profiling feature is not disabled and to enable it you need to build it again with that particular feature enabled. Merely creating temporary table by the name of "PROFILING" will not solve the purpose –  shubhansh Sep 26 '12 at 13:51
    
It was automatically created. I'm not 100% sure on what to do. –  John Brown Sep 26 '12 at 14:07
    
Don't backup information_schema –  kormoc Jun 3 '13 at 23:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.