Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How do I modify the user interface language in SQL Server Management Studio?

For instance, if I installed in English, but wish to view in Japanese (to name but one possible example).

I am running this environment in a non-[English-as-a-first-language] environment, and would prefer all my windows to read in my natural language. (my particular natural language isn't really important is it?)

share|improve this question
up vote 6 down vote accepted

This might help:

Install SQL Server 2008 R2 on a Multilingual User Interface (MUI) system on MSDN by Peter Saddow

From that link:

In summary:

  • English SQL Server is supported on all localized versions of operating systems
  • Localized versions of SQL Server are supported on the same localized operating system or English system with MUI enabled for the same language.

You can also reinstall it using a different language version of SQL Server.

share|improve this answer

To change the language in Microsoft SQL Server Management Studio 2014:

> Tools > Options... > Environment > International Settings > Language

see the screenshot

share|improve this answer
    
It's good way to change it, but there is nothing about how to add a language to list. – Alex Zhukovskiy Apr 12 at 11:23
    
You need to change Windows regional standards and language to English. Windows prompt you for restart. -> open SSMS again and you should be good to go – Vojta Apr 13 at 13:13
    
I installed another lang pack but i still unable to choose english. I want to keep my system language as it is (non-eng) with dev tools using english (MSVS/SSMS and so on). Is it possible? Becuase language pack is on the system but list is still single-element one. – Alex Zhukovskiy Apr 13 at 13:28
    
My configuration: 1) windows 7 - german 2) SSMS - (installed by someone else) - german 3) regional settings - english -- as you see from screenshoot I do have both options – Vojta Apr 13 at 15:43

You will need to change your regional settings within Windows. Once you set your region and language preference your UI should be updated.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.