Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have installed PostgreSQL 9.1 on ubuntu 12.04 64-bit. I try to run Aplication Stack Builder and install pgAgent.

At first I am asked for root password, which I provide, after I choose PostgreSQL 9.1 on port 5433 as the only option. On next screen I tick pgAgent and click Next a few times to get to the Setup screen with verification the postgradeSQL installation details. The Host is local, the User Name is postgres and I type my password for postgrade which I use when open pgAdmin III. When I click next I have a warning:

psql.bin: could not connect to server: Connection refused

Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connection on port 5432?

When I try pgAdmin it does work with password I provide but it looks for me like this password is not accepted by Stack Builder. I also provide my root password on the beginning so it should be able to do everything with sudo privilege. I don't know what to do now and what is the problem. Should I run something else before Stack Builder?

I know it seems like password problem but I tried all and it is not a simple password case. Did anyone have similar problem or know what to do?

share|improve this question

closed as too localized by Jack Douglas Nov 11 '12 at 17:11

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Cross-post of askubuntu.com/questions/215525/… –  Craig Ringer Nov 11 '12 at 3:07
    
... AND cross-posted to stackoverflow.com/q/13323936/398670 as well –  Craig Ringer Nov 11 '12 at 9:34
    
It's good to see you got your answer on all three sites :) now we know that the problem was a simple typo I'm closing the question because it is too specific to be helpful to other visitors. –  Jack Douglas Nov 11 '12 at 17:11
add comment

1 Answer 1

up vote 2 down vote accepted

You write:

I choose PostgreSQL 9.1 on port 5433

The error message says:

Is the server running on host "localhost" (127.0.0.1) and accepting TCP/IP connection on port 5432?

Emphasis mine. Who is wrong? Seems like you are connection to the wrong port / db cluster.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.