Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My SQL Server 2008 R2 doesn't work after changing the MAXDOP parameter on instances.

I have 6 instances located on the same physical server and I changed MAXDOP from 1 to 2 on 5 instances. After that all these 5 instances don't work. After restart of the server any services don't start and I just see the error

The request failed or the service did not respond in a timely fashion. Consult the event log or other application error logs for details

In Event Viewer I didn't find anything useful, also error log wasn't updated when I tried to run instance.

Also I noticed a strange thing. When I open the Configuration Manager and open properties of instance, I don't see the fonts of parameter's name in Advanced tab. In another tabs everything is fine. The screen is attached. Does anybody faced the same problem?

I don't have any idea how repair this...


upd: By the way, i tried start sql server manually from command line with -f or -m parameter but nothing.. I just see empty error window


migration rejected from Nov 6 '13 at 14:15

This question came from our site for professional and enthusiast programmers. Votes, comments, and answers are locked due to the question being closed here, but it may be eligible for editing and reopening on the site where it originated.

closed as off-topic by billinkc, Max Vernon, Paul White, Mike Walsh, Jon Seigel Nov 6 '13 at 14:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Too localized - this could be because your code has a typo, basic error, or is not relevant to most of our audience. Consider revising your question so that it appeals to a broader audience. As it stands, the question is unlikely to help other users (regarding typo questions, see this meta question for background)." – billinkc, Max Vernon, Mike Walsh, Jon Seigel
If this question can be reworded to fit the rules in the help center, please edit the question.

What is the source of that error message? sqlservr.exe? – usr Nov 17 '12 at 14:14
Did you try to run chkdsk? Especially on C:\ drive? I think you should check this also... – Boris Hristov Nov 18 '12 at 6:34
What is your server configuration? Number of cores? Amount of RAM? Drive layout? (where are the MDF, LDF files located, where is MSSQL?) What eventlog entries did you have during the change of MAXDOP? – hot2use Nov 20 '12 at 8:35
Maxdop setting does not and will not make sql server not to start. There might be something else going on. Can you post a. Error log message b. Output of systeminfo. – Kin Mar 15 '13 at 20:44
You say you looked at the event viewer, but this is not the same as the SQL Event Log. This is typically found in ..\Program Files\Microsoft SQL Server\<Version/Instance ID>\MSSQL\Log. See if you have any messages in there. – Mike Fal May 20 '13 at 15:42

This may not be fixed by the SQL restart alone :

1) Set all of the SQL instances to be started manually at restart

2) Restart the windows Server

3) Start one SQL instance at a time manually and reset the MAXDOP to a smaller number.

4) check each instance for any issues before starting the next one.