Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

How can I force SSMS to forget the recently used logins?

Of course I use "SQL Server Authentication" with Login/Password fields.

(It get's annoying, as everytime I open SSMS it shows the "Connect to Server"-Dialog, with a login preselected that is not valid anymore.)

Didn't find any option, and no info here.

Thank you.

share|improve this question
    
I haven't installed SP3 yet, I try this now to see if it maybe resolves the problem (same as using SSMS 2012 would). –  SwissCoder Nov 26 '12 at 5:33
add comment

2 Answers

up vote 3 down vote accepted

If you move to SQL Server 2012 Management Studio (and no reason not to, now that it's free and you can still manage the same set of down-level servers that 2008 R2 lets you manage), you can simply delete old servers right from the connection dialog using the standard Delete key.

http://blogs.msdn.com/b/managingsql/archive/2011/07/13/deleting-old-server-names-from-quot-connect-to-server-quot-dialog-in-ssms.aspx

share|improve this answer
1  
It would have been nice if they had implemented the same delete logic for the login list, too. (Edit: Whoops. Accidentally tested on the wrong box.) –  Jon Seigel Nov 23 '12 at 18:11
    
What you mean by free Aaron? I am a bit reluctant to istall the express edition, I don't want to have too many installs. Since when is the full version free? –  SwissCoder Nov 26 '12 at 5:02
    
Well from the SQL Server Express Download page microsoft.com/en-us/download/details.aspx?id=29062 the Management Studio is a separate download, so I guess that's what you mean. I'm currently installing it, thank you for the hint! –  SwissCoder Nov 26 '12 at 5:31
    
@SwissCoder no, did you read my blog post? I think you'll need the SP1 version from microsoft.com/en-us/download/details.aspx?id=35579 –  Aaron Bertrand Nov 26 '12 at 13:47
    
I read your blogpost, but didn't realize ur link for Express SP1 would point to the full installer. Unfortunately Windows Update seems to be unaware of the SP1, so I have to go for a full download/install again.. (300MB more than the pre SP1 Version, I wonder what they packed in there additionally!) –  SwissCoder Nov 27 '12 at 4:54
show 1 more comment

Try to delete the following file and open the SSMS and see.

C:\Users\gowdhdhan\AppData\Roaming\Microsoft\Microsoft SQL Server\100\Tools\Shell\SqlStudio.bin

Hope this helps!

share|improve this answer
1  
Thank you Gowdhaman, but I think I will not simply delete all this file, as I see there are many other settings stored in this file as well (for example: Microsoft.SqlServer.Management.UserSettings.QueryExecutionSettings). Actually I found the user in there and tried to remove it from that configuration, but when I reopen SSMS it will add the user again to this file... –  SwissCoder Nov 23 '12 at 8:08
    
Did you deleted alone SqlStudio.bin file. that resolved my problem. –  Gowdhaman Dhandapani Nov 23 '12 at 9:49
    
Hello Gowdhaman, I can deelete only this file, but then I loose other information. I want to explicitly only loose the information for the logins, or better for 1 specific login only. –  SwissCoder Nov 23 '12 at 11:16
    
I dont think we can do that, because SqlStudio.bin file is the binary file and its very dangerous to edit in binaries. –  Gowdhaman Dhandapani Nov 23 '12 at 11:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.