Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I'm able to connect to my PGSQL database from SSHv2.

But when I try to do the same thing on MicroOLAP Database Designer, I get this message:

(Note: From my college PC, I can connect. But I can't connect from home.) enter image description here

My configuration:

enter image description here enter image description here

Here's me on arka.foi.hr via SSHv2 (accessible from home):

enter image description here

share|improve this question
    
you should show also pg_hba.conf it is most important information in connection settings. –  sufleR Dec 7 '12 at 9:17
    
Any improvement on this? –  dezso Dec 10 '12 at 21:52
    
Nope. I asked a colleague on college, and he can't connect either. But I will accept your answer since it's technically correct :). –  Tool Dec 11 '12 at 1:26
    
You shouldn't accept an answer which does not solve your problem. Instead, when you discover the real solution, post it as an answeer yourself and accept it. –  dezso Dec 11 '12 at 5:46
    
My problem doesn't really exist. I posted the question in belief that it was my fault I can't connect, which is not true - the administrator disabled external connections. –  Tool Dec 11 '12 at 23:20

1 Answer 1

up vote 1 down vote accepted

From the error dialog it is clear that something around your connection is wrong.

First be sure that everything you included here matches: you have an error about localhost and port 3082 and you present a connection dialog with a foreign host and port 5432.

Then you have to teach PostgreSQL that it should accept connections from your home. This can be done via the pg_hba.conf file. You will need a line added like this (the header is already there) - if you don't have access to it, ask the person in charge of it to do this:

# TYPE  DATABASE        USER            ADDRESS                 METHOD
host    dnizetic        dnizetic        161.53.120.19/32        md5
share|improve this answer
    
Do you mean teaching my local PGSQL or remote PGSQL? Because I can't change pg_hba.conf on the remote machine - I don't "own" the server's PGSQL. (I also looked for such file on my machine, and I can't find it - but I doubt you meant that). –  Tool Dec 7 '12 at 9:25
    
The presented error matches the input images I've uploaded. I checked this twice. –  Tool Dec 7 '12 at 9:27
    
@Tool Is your local machine at home arka.foi.hr? If not, then at least one of us don't understand something :) All in all, do you want to connect to your local PostgreSQL or the remote one? –  dezso Dec 7 '12 at 9:40
    
The remote one. No, my local machine is localhost (127.0.0.1). arka.foi.hr is a remote IP. –  Tool Dec 7 '12 at 10:04
2  
Is the SSH tunneling correctly configured? You haven't showed us the MicroOLAP tunneling configuration. –  ypercube Dec 7 '12 at 10:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.