Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

11.70.FC6 Developer Edition on Windows 7 Pro 64-bit:

  1. Downloaded via IIUG link and installed it.
  2. I created a custom DSS instance named "server" with a 128GB dbspace named "datadbs".
  3. Install wizard created a Windows user "informix".
  4. I connected to instance "server", logging in as "informix".
  5. Executed an SQL script "CREATE DATABASE voters IN datadbs NLSCASE INSENSITIVE;"
  6. This failed (see first image), then tried creating the db via dbaccess menu.
  7. In dbaccess, dbspaces options did not show "datadbs", only root, phys, log & sbs dbs', but when I do a dir of the dbspaces it shows "datadbs" with 107GB (see second image).
  8. I set the following values in "onconfig.server" (see third image), but still no dice!

enter image description here enter image description here enter image description here enter image description here

share|improve this question

migrated from stackoverflow.com Dec 10 '12 at 17:21

This question came from our site for professional and enthusiast programmers.

    
Can you explain why you want to close a valid informix question? –  FrankComputerAtYmailDotCom Dec 10 '12 at 16:50
    
I believe the question is being voted to move onto DBA - where it is more likely to be answered. –  Steve Fenton Dec 10 '12 at 17:20
add comment

3 Answers 3

up vote 1 down vote accepted

Since the datadbs file is not anywhere near 128 MiB, I wonder if you were successful in adding that dbspace. One might be forgiven for thinking that in fact you were unsuccessful since the database server doesn't think it exists.

Use 'oncheck' or 'onstat' (or both) to check whether the dbspace exists and is intact. If not, arrange to drop it, or simply remove the datadbs file and try again with the onspaces command.

share|improve this answer
    
When I installed DE on Windows, I used the install wizard to create the custom 128GB dbspace. However onstat -d does not show it. –  FrankComputerAtYmailDotCom Dec 11 '12 at 16:37
    
Not good. Did you run out of disk space? If onstat -d does not show it, then you can remove the file and do the onspaces command suggested by rok observing its output and exit status (and double-checking with onstat -d). Either way, there is little doubt that it should have worked via the wizard, and there might be cause for reporting a bug to IBM. –  Jonathan Leffler Dec 11 '12 at 16:46
    
I have a 1TB disk. I deleted the instance with the "Server Instance Manager" wizard for Windows, created a new custom instance with only 7.68GB dbs and that worked. However, the install wizard and instance manager did not prevent me from specifying a dbspace >8GB which apparently is the restriction for 11.70.DE. In reality, you cant define dbspace >7.68GB. It will create the dbs file on disk, but doesn't show in onstat or dbaccess.. bug? –  FrankComputerAtYmailDotCom Dec 11 '12 at 21:29
add comment

How did you create the dbspace ? I'm a bit astonished that you showed up a directory listing instead of the output from onstat -d - just creating a file does not do the job. Run onstat -d and see if there is a dbspace called "datadbs". If not, cd to the directory where the dbspace should reside, create a suitable file (i. e. echo gaga >datadbs content does NOT matter) and create the dbspace using "onspaces". This should look similar to

onspaces -c -d datadbs -p c:\dbspaces\datadbs -o 0 -s 128000000

For more options enter onspaces -?

Hope this will help

share|improve this answer
add comment

I just had a look at IBM's web site. They clearly state that storage for Dev-edition is limited to 8 GB and I suppose this includes the other dbspaces as well. Anyway, this "wizzard" should have told you about the error ... Did you take a look at he logfile ? It's quite a while ago that I last worked with Informix on Windows but I could never get used to these "tools". My personal preference is using "onstat", "onspaces" and friends from a shell. OAT is approachable (sometimes even excellent ;-) ).

If you are not stuck to the more elaborate features of IDS, Innovator-C might be a good choice. IBM states it is "Limited to 1 core and 2GB of memory. Allows unlimited data storage." For many cases that's still a lot, but of course it depends on what you want to do with the server.

Greets

[edit]

you wrote " It will create the dbs file on disk, but doesn't show in onstat or dbaccess.. bug?"

I do not think it is a bug, let's call it a "feature". IDS will not create the file for you, it must already exist. This a very reasonable behaviour, it prevents you from accidentially creating a file in "/dev" under UNIX or Linux instead of using a raw device.

So I suppose the tool will first create the file but IDS will refuse to populate it in the specified size.

share|improve this answer
    
OK, my point is why does the server manager tool allow you to define a dbspace >8GB with no warning and create the dbs file on disk? My requirement is for a DSS with 128GB storage. –  FrankComputerAtYmailDotCom Dec 13 '12 at 3:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.