Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am trying to install SQL Server Enterprise Core 2012 w SP1 64bit (as downloaded from the Microsoft Partner Program site) on a 64-bit Windows 2008 R2 SP1 server. When simply right-clicking on SETUP.EXE in the root and selecting Run as Administrator, seemingly nothing happens. When I run it from a Command Prompt (Run as Administrator), I get this:

An error occurred during the SQL Server 2012 Setup operation.

Error result: -2067529723 Result facility code: 1220 Result error code: 5

For more information, review SQL Server 2012 Setup logs in your temp folder.

No log files were written anywhere. How can I find out what this error is trying to tell me and what I can do to resolve it?

share|improve this question
1  
Just for clarification, that error number is 0x84C40005 in hex. Typically, the hex number is mentioned in Microsoft documentation. In fact, there is a document about this problem with SQL 2008 here: social.msdn.microsoft.com/Forums/en-US/sqlexpress/thread/… I don't know if that is the same issue. –  Max Vernon Dec 10 '12 at 21:27
    
I'd suggest you may need to re-download the setup package as a first try. –  Max Vernon Dec 10 '12 at 21:27
    
Max, I did download the the ISO a second time. I doubt that it is corruption in the ISO or I would have had trouble extracting it. –  Mark Dec 11 '12 at 14:45
    
The Setup dies before creating and files or folders within either the Program Files or Program Files (x86) folder trees. The machine already has instances of 2005 and 2008 R2 installed on it (it is a development server), so I know that any prerequisites for those versions have already been met and I am unaware of any new ones for 2012. –  Mark Dec 11 '12 at 14:54
    
I did find this "The installation of SQL Server 2012 fails if you launch the setup through Terminal Services Client. Launching SQL Server Setup through Terminal Services Client is not supported." The server I am installing on is a VM and I can only access it using Remote Desktop. Could this be an issue? –  Mark Dec 11 '12 at 14:56

2 Answers 2

up vote 0 down vote accepted

I rebooted the VM, and I was then able to get the Setup to work as expected. I am disappointed that the error message did not provide any indication of what was wrong or what needed to be done to correct the situation, but rebooting seems to have resolved whatever the issue was.

share|improve this answer

I had the same error message as yours. I found out that my environment variable temp was pointing to an existing file, when it should be a directory.

After renaming the original file and creating a directory instead, the installation proceeded.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.