Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I installed a new version of MySQL server (previously 5.0, now 5.5) and I copied the data folder in to the new one. Now I should perform mysql_upgrade. I opened the command prompt (server is located on Windows Server 2012) and used cd to get in the bin folder. I wrote the file name to run the upgrade. The result was mysql_upgrade: unknown option '--no-beep'. What's that? I tried to do some research on Google, but no one seemed to have the same error.

I'm confused. Even the MySQL documentation doesn't seem to tell anything about the error.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The no-beep option causes the mysql command line client not to beep when errors occur.

If that's an option you want, it should be in the [mysql] section of your my.cnf. This error suggests that it's in the [client] section of your my.cnf, which causes mysql_upgrade to throw the error since the option isn't recognized.

Check your my.cnf and either remove the line or place it in the [mysql] section instead of [client] and you should be good.

The [client] option group is read by all client programs (but not by mysqld). This enables you to specify options that apply to all clients. For example, [client] is the perfect group to use to specify the password that you use to connect to the server. (But make sure that the option file is readable and writable only by yourself, so that other people cannot find out your password.) Be sure not to put an option in the [client] group unless it is recognized by all client programs that you use. Programs that do not understand the option quit after displaying an error message if you try to run them.

-- http://dev.mysql.com/doc/refman/5.5/en/option-files.html

share|improve this answer
    
Thanks! Found it in my.ini and removed it. Now it works! –  MikkoP Dec 19 '12 at 7:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.