Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I am using MySQL server 5.1.51 on a Linux machine.

The application was working fine for the last 32 days, but since yesterday a number of clients are not able to connect to the database from our application. They are getting the following error:

-2147467259 [MySQL] [ODBC 5.1 Driver] Lost Connection to MySQL server 
       at 'waiting for initial communication packet',system error: 0

What can I do to fix this? Where is my.ini located in Windows XP?

share|improve this question
    
Wow! Many thanks! You solved my problem. After a black out my machines were unable to dialog to a MySQL server 'cos they got always the "Lost Connection to MySQL server at 'waiting for initial communication packet',system". But, with your advice about "skip_name_resolve" now everything works fine! Thanks again. –  user29142 Oct 8 '13 at 15:14

1 Answer 1

Adding the following database parameter to my.ini solved my problem:

skip_name_resolve 

This parameter skips host name resolution during connection establishment with the MySQL database server.

share|improve this answer
    
Wow! Many thanks! You solved my problem. After a black out my machines were unable to dialog to a MySQL server 'cos they got always the "Lost Connection to MySQL server at 'waiting for initial communication packet',system". But, with your advice about "skip_name_resolve" now everything works fine! Thanks again. –  user29142 Oct 8 '13 at 15:14
    
+1 for finding your own solution after 3 months –  RolandoMySQLDBA Apr 7 at 15:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.