Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I ran the following command from the command line on SQLServer 2008 R2

BCP C4L.dbo.districts in C:\TEMP\districts.sdf -f C:\TEMP\districts_import.fmt -T'

No errors were reported and it ran as expected, taking an expected amount of time and reporting the correct number of records imported. However, the count on the table is still 0. Same result with a second file I attempted to import into a another table

The database was in BULK_LOGGED mode. The target table was newly created without any indexes.

Any help would be appreciated.

share|improve this question

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.