Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

If you have a SQL Server Cluster called CLS, with machines CLS1 and CLS2, accessing:

\\CLS\network\path

is equivalent to accessing either

\\CLS1\network\path

or

\\CLS2\network\path

depending on whether CLS1 or CLS2 is the currently active instance.

The same behavior isn't occurring on a SQL Server 2012 Availability Group I've set up to try out AGs. I have three machines called PRI, SEC1 and SEC2 in an availability group called AG. I can access the databases via AG, and can remote desktop AG, but cannot access network shared via AG.

  1. Are you supposed to be able to, by default, access networks shares via the AG?
  2. If not, can this behavior be enabled?

Edit: I am primarily interested in the administrative shares (c$, d$ etc.)

share|improve this question
add comment

migrated from stackoverflow.com Dec 19 '12 at 16:05

This question came from our site for professional and enthusiast programmers.

2 Answers

CLS is not an alias for either CLS1 or CLS2. CLS is a cluster, not a real machine. You cannot access \\CLS\c$ simply because no such thing exists. There is only \\CLS1\C$ and \\CLS2\C$ and you can access either of them. You should figure out which one is the one you're interested and access that.

share|improve this answer
add comment

You need a shared disk inside the resource group to be able to add a shared folder in WFC.. So

\\CLS\path

Will only work if "path" is a shared folder on one of the SAN drives of the SQL Server Instance (if you share a folder on CLS1's C: drive it will not show up in \CLS even if CLS is on CLS1), this is because the "fileserver" resource in the resource group will fail if the resource group fails over and does not find the same C: drive as that on CLS1 on CLS2

Since AlwaysOn uses Standalone SQL Servers (only one resource group for the listener, with just an IP), it will not allow you to create a shared folder.. If you need a shared folder, you will need to do the following

  1. Add a shared (clustered) drive to the Listener Resource Group
  2. Right Click the resource group and choose "create a shared folder"
  3. This share will then access from \AG\SharedFolder, where SharedFolder is a folder on the clustered drive from step 1
share|improve this answer
    
I seem to be able to access \\CLS\c$, and it passes through to \\CLS1\c$ or \\CLS2\c$ appropriately. I tested it was actually working by creating a blank text file on \\CLS\c$, it then appeared on \\CLS1\c$ but not on \\CLS2\c$. –  Mark Raymond Dec 19 '12 at 21:38
    
It does not apply to dollar shares, try it with a shared folder.. –  Rohan Dec 20 '12 at 5:22
    
Ah, sorry, I should have been more specific. It's the administrative/dollar shares that I am primarily interested in. I have updated the question. –  Mark Raymond Dec 20 '12 at 9:04
    
so i tried accessing \\CLS\c$ (note, by c drive I mean a drive that is not shared, and windows is installed on it), it did not work, with the same error "network path not found" –  Rohan Dec 20 '12 at 13:42
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.