Take the 2-minute tour ×
Database Administrators Stack Exchange is a question and answer site for database professionals who wish to improve their database skills and learn from others in the community. It's 100% free, no registration required.

I have some reports which I access through the Report Manager interface and view using a Report Viewer. If I leave a report open in the viewer then my session never times out. I believe this is because the viewer "pings" just before the session is due to time out, thus keeping the session alive.

This isn't very desirable and I would like to somehow set the viewer so that this "ping" doesn't happen. I have been trying to find a way to do this and have been coming up short as there is no obvious reference to this property in the config files or the site settings. I have found a number of references on the web to people having timeout issues using the reportviewer control in a .NET application, but none just using SSRS.

Is it possible to change this "ping" setting somehow? If so could somebody be so kind as to guide me through it as I am struggling.

share|improve this question

migrated from stackoverflow.com Jan 14 '13 at 18:39

This question came from our site for professional and enthusiast programmers.

1 Answer 1

You are probably looking for the KeepSessionAlive property of the ReportViewer control. To quote the linked MSDN page:

ReportViewer.KeepSessionAlive Property

Property Value
true to keep the user session from expiring; otherwise, false. The default is true.

Setting this property to true causes the ReportViewer control to keep the ASP.NET session from expiring if session is enabled in your ASP.NET application. Also, in remote processing mode, it causes the ReportViewer control to keep the report server session from expiring.

You should be able to set this property to false to prevent the keep-alive calls.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.